Playermodels im Pointshop als error angezeigt

Dieses Thread wurde bereits als "erledigt" markiert, erstelle bitte ein neues Thread für dein Anliegen.
  • Habe mir 2 Playermodels in den Pointshop eingefügt. Nach langem bearbeitet sind die endlich drin, werden aber nur als error angezeigt.
    Hat jemand einen Tipp für mich? ?(

  • Du musst den ordner mit den Dateien für den Skin in den addons ordner ziehen. anschließend erstellst du eine lua-Textdatei, welche du in den ordner "addons/pointshop-master/lua/pointshop/items/playermodels" erstellst.
    anschließend kopierst du das hier in die lua-textdatei.


    ITEM.Name = 'Harley-Quinn'



    ITEM.Price = 250





    ITEM.Model = 'models/player/harleyq/harleyq.mdl'


    function


    ITEM:OnEquip(ply, modifications)





    if not ply._OldModel then





    ply._OldModel = ply:GetModel()





    end










    timer.Simple(1, function() ply:SetModel(self.Model) end)





    end










    function ITEM:OnHolster(ply)





    if ply._OldModel then
    ply:SetModel(ply._OldModel)





    end
    end










    function ITEM:PlayerSetModel(ply)





    ply:SetModel(self.Model)


    end


    In der Zeile "ITEM.Model = 'models/player/harleyq/harleyq.mdl' " musst du die passende mdl-datei verlinken.
    dazu suchst du diese in dem Skin-Ordner, indem du unter "models" die passenden Dateien reinschreiben.


    dann nurnoch speichern, neu hochladen und die Skins sind ohne error im spiel.


    Falls noch Fragen aufkommen sollten, einfach melden ^^

  • Hey habe das selbe Problem, habe alles gemacht wie beschrieben, jedoch werden sie als Error angezeigt und oben links beim joinen steht "something is causing a script error".
    Ich poste mal meine beiden .lua files:



    und