BEC (Battleye Extendet Controls) UPDATE + SCHEDULER

Dieses Thread wurde bereits als "erledigt" markiert, erstelle bitte ein neues Thread für dein Anliegen.
  • Hallo Community,
    wir hatten in letzter Zeit vermehrt die Anfrage bezüglich Scheduler Nachrichten.


    Battleye funktioniert nicht.
    Bei Epochmod.com im ordner /HauptverzeichnisARMA3/Battleye/beserver.cfg
    in der Datei schaun ob ein doppelter Rcon eintrag vorhanden ist oder die Datei selbst doppel vorhanden ist.
    Leider buggt hier der Gameserver von der Software her und kann sein das eines der oberen Probleme auftritt.
    Desweiteren schaun ob eine Bans.txt vorhanden ist!


    Bei normal Arma 3 mit Altis Life im ordner /HauptverzeichnisARMA3/config/Battleye/beserver.cfg
    in der Datei schaun ob ein doppelter Rcon eintrag vorhanden ist oder die Datei selbst doppel vorhanden ist.
    Leider buggt hier der Gameserver von der Software her und kann sein das eines der oberen Probleme auftritt.
    Desweiteren schaun ob eine Bans.txt vorhanden ist!


    Bei normal Arma 2 im ordner /HauptverzeichnisARMA2/config/Battleye/beserver.cfg
    in der Datei schaun ob ein doppelter Rcon eintrag vorhanden ist oder die Datei selbst doppel vorhanden ist.
    Leider buggt hier der Gameserver von der Software her und kann sein das eines der oberen Probleme auftritt.
    Desweiteren schaun ob eine Bans.txt vorhanden ist!



    Dan sollte BEC laufen! dies erkennt man wenn man !upt ingame macht dan sollte uptime erscheinen ein zeichen dafür das es läuft.


    so nun zur restart anzeige!
    im Ordner /HauptverzeichnisSERVER/BEC/config/Scheduler.xml
    hier mal eine Beispieldatei von uns




    Michael Scheid
    Systemadministrator
    ________________________________________

    OCIRIS GmbH
    Aidebachstraße 54

    81379 München
    Tel.: +49 (0) 69 380 766670
    Fax: +49 (0) 69 380 766689
    ________________________________________

    Geschäftsführer: Sebastian Reckzeh, Roberto Omezzolli
    Handelsregister: Amtsgericht München, HRB 146467
    Sitz der Gesellschaft: München

  • Habe folgenden Scheduler.xml:



    Habe den Scheduler hier aus dem Beitrag kopiert und eingefügt und nur angepasst. Zeiten sind alle gleich geblieben. JEtzt gibt er mir im Error Log folgendes aus:


    Bräuchte Hilfe.


    Danke.

  • Für die Meldungen der Restarts must du folgende Zeitanzeige nehmen:


    <job id="26">
    <day>1,2,3,4,5,6,7</day>
    <start>17:59:00</start>
    <runtime>000000</runtime>
    <loop>0</loop>
    <cmd>say -1 Achtung Achtung, Restart in 1 Minute</cmd>



    Sekundenangaben für restart bringen rein garnix....bestes interval wäre 1 Stunde, 30min, 15min, 10min , 5min und max 1 min


    Ich kann gerne mal meine Scheduler als Beispiel anhängen:



    Lg Jürgen

  • Hallo Zusammen.


    Bei mir scheind BEC garnicht zuarbeiten. Es kommen keine Nachrichten.


    BEC ist an und hier ist meine Scheduler:



    Viele Grüße


    Edit: BEC scheind garnicht zu Arbeiten, es werden auch keine Chatlogs gespeichert.


    Glaube habe den Fehler gefunden. Es stand 2x ein Rcon Passwort drin :(

    Marco Petersen

    Support

    ________________________________________

    OCIRIS GmbH

    Ortnistraße 9

    81925 München

    Tel.: +49 (0) 69 380 766670

    Fax: +49 (0) 69 380 766689

    ________________________________________

    Geschäftsführer: Sebastian Reckzeh, Roberto Omezzolli

    Handelsregister: Amtsgericht München, HRB 146467

    Sitz der Gesellschaft: München

    The post was edited 2 times, last by Gotteshand ().


  • Sekundenangaben für restart bringen rein garnix....bestes interval wäre 1 Stunde, 30min, 15min, 10min , 5min und max 1 min

    Hallo,


    danke für deine Hilfe. Jedoch arbeit ich schon seit jeher auch mit Sekunden und bis dato gab es nie Probleme damit. Weder Anfangs hier, noch auf anderen Servern. Und ich benutze zu 90% identische Schedule.xml. Das Problem war wohl Anfangs gewesen, dass mein BEC noch das ältere Format wollte. Wurde aber vom Support geändert.


    Dann hatte ich jetzt jedoch das Problem, dass mein BEC nach dem 12 Uhr Reset wohl nicht mehr anspring. Es kamen weder BEC Meldungen, welche eigentlich mind. alle 30 min kommen, noch kam die Info des Server Restarts dann um 16 Uhr. Somit wurde der Server restartet ohne Meldung, was natürlich gar nicht schön war und ich den 16 Uhr restart erstmal deaktivieren musste.


    Habe jetzt den Server neuinstalliert, da ich eh alle Scripte neu installiert und angepasst habe, sodass meine Logs fast sauber sein werden. Mal schauen, ob der Fehler mit dem 12 Uhr Restart jetzt weiter auftauchen wird.

  • Also bei mir gehts leider nicht. Ich habe das Obere überprüft und habe RCon NICHT 2x stehen und ban.txt ist auch vorhanden. Ich habe schon einige Scheduler Dateien getestet. Nix - leider


    Gibts noch etwas, was ich kontrollieren sollte?

  • Also bei mir gehts leider nicht. Ich habe das Obere überprüft und habe RCon NICHT 2x stehen und ban.txt ist auch vorhanden. Ich habe schon einige Scheduler Dateien getestet. Nix - leider


    Gibts noch etwas, was ich kontrollieren sollte?


    Ich wollte jetzt direkt mal nachschaun was in ihrem Server eventuell falsch läuft.
    Leider haben Sie gar keinen Arma Server :/

    Michael Scheid
    Systemadministrator
    ________________________________________

    OCIRIS GmbH
    Aidebachstraße 54

    81379 München
    Tel.: +49 (0) 69 380 766670
    Fax: +49 (0) 69 380 766689
    ________________________________________

    Geschäftsführer: Sebastian Reckzeh, Roberto Omezzolli
    Handelsregister: Amtsgericht München, HRB 146467
    Sitz der Gesellschaft: München

  • Moin,


    bei mir scheint BEC auch nicht zu funktionieren.


    Ich habe Exile Mod, InfiStar, DMS und Status Bar installiert


    Bei mir gibt es keine BEServer.cfg nur die hier: config\battleye\BEServer_active_185b.cfg


    hier steht folgendes drin:




    Ich habe den doppelten Eintrag schon öfters gelöscht, aber er wird immer wieder mit eingetragen.


    Kann jemand Helfen?

  • Code: BEServer_active_xxxx.cfg
    1. MaxPing 369
    2. RConPassword xxxxx
    3. RConIP xx.xxx.xxx.xxx
    4. RConPort 2306

    So sollte deine BE config aussehen.
    Die doppelten Einträge löschen und am besten via FTP Programm bearbeiten. Seither habe ich auch keine doppelten Einträge mehr da dies wohl systemtechnisch noch fehlerhaft ist.


    Und das sich die beserver.cfg umbenennt sobald du den server startest ist normal. :-)


    Um zu kontrollieren ob BEC läuft gib
    #beclient players
    ein. Dann solltest du eine Info bekommen.

    The post was edited 1 time, last by Buly ().