Nach Restart immer in Creative

Dieses Thread wurde bereits als "erledigt" markiert, erstelle bitte ein neues Thread für dein Anliegen.
  • Huhu,


    grad frisch n Server angelegt, alles soweit eingestellt (hoffe ich :D ), drauf gegangen un bissl rumgeschaut.
    Nachträglich Mods installiert, neue Welt dabei generiert (vergessen umzustellen, war aber wegen den Mods wohl besser).


    Server hat im Survival gestartet, kurz draufgegangen, den ersten Autosave abgewartet, runter vom Server, Server runtergefahren. Worldsave umgestellt, Server gestartet, und dann ist der Server im Creative!
    Das ganze auch ohne Mods ausprobiert, gleiches Problem.


    Siehe:
    https://gyazo.com/2e4b679f67f108f20caaf43333471a7b
    https://gyazo.com/7d953f01379e3aa4cb3c42f99320e5cf


    SpaceEngineers-Dedicated.cfg: <GameMode>Survival</GameMode>
    SpaceEngineersDedicated.log: 2015-11-13 23:34:45.880 - Thread: 1 -> GameMode = Creative


    Wie behebe ich das Problem?

  • Ich habe dieses Problem auch schon im Forum von Keen gesehen und hatte es auch selber.


    Ich habe folgendes dem User bei Keen geschrieben:




    Bei mir hat es so funktioniert. Es ist bei einer bestehenden Welt auch möglich, aber um einiges Schwieriger

  • Habs getestet, hat leider keinen Erfolg gebracht. Auch nicht mit anderem Weltnamen. Einzig die Spawn-Auswahl ist nun auch im Creative vorhanden :(

  • Habe momentan das selbe Problem. Habe auch schon den Support per Ticket angeschrieben. und wir arbeiten daran das Problem zu lösen.

  • und da kriege ich als ich das Problem gestern per Ticket melde noch die Aussage "das liegt nicht an uns"


    lustig, dass ich noch bis heute restzeit bei nem anderen Server Provider hatte und da alles wie geschmiert lief


    naja hoffentlich wird das bis heute Abend gefixed

  • Das Problem ist, dass in der Sandbox.sbc folgende Zeile fehlt:


    <GameMode>Survival</GameMode>


    Diese wird jedes Mal gelöscht, wenn man den Server startet ohne die oben beschriebene Einstellung zu machen. Man muss diese Zeile einfügen und die Einstellungen s.o. gemacht haben.


    So läuft es jetzt auch bei uns.

  • es leuft überall besser als hier und ticket schreiben is sowieso sinnlos bekommt man net wirklich antworten woran es liegen kann geschweige den ob daran gearbeitet wird na ja ich werd mich nach diesem gefühlten 100ten problem von hier verabschieden

  • Hallo,


    Sie müssten derzeit in der Sandbox.sbc den Gamemod manuell auf Survival umstellen.
    Dies geht wie folgt!
    Via FTP auf den Server connecten
    https://www.g-portal.com/wiki/…_auf_meinen_FTP_Server%3F
    als nächstes in den ordner \profile\Saves\IHRSAVEGAME\
    Dort öffnen sie die Datei Sanbox.sbc
    per STRG + F suchen sie nach GameMode und ändern diesen auf Survival um datei abspeichern Server starten :)


    Ich habe das Problem schon an unsere Technick weitergegeben und hoffe das die hierfür einen baldigen fix raus bringen.

    Michael Scheid
    Systemadministrator
    ________________________________________

    OCIRIS GmbH
    Kistlerhofstr. 70

    81379 München
    Tel.: +49 (0) 69 380 766670
    Fax: +49 (0) 69 380 766689
    ________________________________________

    Geschäftsführer: Sebastian Reckzeh, Roberto Omezzolli
    Handelsregister: Amtsgericht München, HRB 146467
    Sitz der Gesellschaft: München

  • Das hat fuer mich nicht funktioniert. Das erste mal startete der server immer noch in creative. Dann war <GameMode> gar nicht mehr in die .sbc drin. Ich habe die ganze zeil wieder reingepastet und jetzt startet das server gar nicht mehr.


    Unterdessen lässt sich der Server selbst nach Neuinstallation nicht mehr starten

  • <?xml version="1.0"?>
    <MyConfigDedicated xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SessionSettings>
    <GameMode>Survival</GameMode>


    das sind meine ersten 4 Zeilen

  • Trotz ersetzen bzw einfügen des Gamemodes, wird weiter nach serverstart auf kreativ umgestellt. Hoffen wa mal das der fix heute noch kommt.

  • Bei mir ist es Zeile 90. Es ist abhängig von irgendwelchen Einstellungen. Es muss wie Folgt aussehen:


    <Settings xsi:type="MyObjectBuilder_SessionSettings">
    <GameMode>Survival</GameMode>
    <InventorySizeMultiplier>10</InventorySizeMultiplier>
    <AssemblerSpeedMultiplier>3</AssemblerSpeedMultiplier>
    <AssemblerEfficiencyMultiplier>1</AssemblerEfficiencyMultiplier>
    <RefinerySpeedMultiplier>3</RefinerySpeedMultiplier>
    <OnlineMode>PUBLIC</OnlineMode>
    <MaxPlayers>4</MaxPlayers>


    Alelrdings, wenn bestimmte Optionen gesetzt sind, dann funzt es nicht wirklich. Ich konnte bisher nur nicht herausfinden, welche Option es ist.


    Ich hatte die Welt auf meinem Rechner mit der Server-Software gestartet, wodurch die Option eingefügt wurde, die aber nach einem Start auf dem G-Portal Server wieder weg war. Ich bin der Meinung, dass es sich um eine der neuen Optionen handelt.


    Ich hatte die Vermutung, dass es das Starte in Respawn Screen ist. Diese habe ich aber deaktiviert. Nun glaube ich, dass es sich um die Option canJoinRunning handelt, die ich deaktiviert habe.


    Für alle die Wissen wollen, wie es aussieht bei mir schaut auf Pastebin



    Ich habe gerade das Problem wieder gehabt. Es ist die Einstellung: canJoinRunning
    Diese muss deaktiviert sein und die Zeile in der Sandbox.sbc muss drinne sein.

    The post was edited 1 time, last by zombold ().